403 on images

Something not look right? Please explain in detail.

403 on images

Postby coke » Thu Jun 11, 2009 9:25 am

User avatar
coke
 
Posts: 3
Joined: Thu Jun 11, 2009 9:22 am

Re: 403 on images

Postby harknell » Thu Jun 11, 2009 11:01 am

Hi, the permission issue you're seeing is due to "hot link protection" on our images. Most likely this is because you are viewing the pages through a proxy server or some other set up that is relaying the site--in that case the protection sees the proxy server instead of our server as the call to the images (as if say someone had basically done an img src= on their server to our images) and is therefore saying "nope, you can't embed these images in your site. Are you looking at the site from a school or business?
Webmaster for the comic Stupid and Insane Defenders Against Chaos: http://www.onezumi.com
Webmaster for the comic Erfworld: http://www.erfworld.com
harknell
Site Admin
 
Posts: 189
Joined: Fri Dec 19, 2008 10:49 am

Re: 403 on images

Postby coke » Thu Jun 11, 2009 1:33 pm

harknell wrote:Hi, the permission issue you're seeing is due to "hot link protection" on our images. Most likely this is because you are viewing the pages through a proxy server or some other set up that is relaying the site--in that case the protection sees the proxy server instead of our server as the call to the images (as if say someone had basically done an img src= on their server to our images) and is therefore saying "nope, you can't embed these images in your site. Are you looking at the site from a school or business?


Thanks for the quick response; Yah, I'm using squid on my home network as a straight HTTP proxy.

Is the hot link protection part of a toolkit? I'd be happy to poke at the source to offer a patch so it works with a proxy. Probably just needs to respect the proxy headers in the HTTP request if present.

RE-UPDATE: summer update '02' now displays an image; 03 is still a 403. (and 01 works as it always has.)
User avatar
coke
 
Posts: 3
Joined: Thu Jun 11, 2009 9:22 am

Re: 403 on images

Postby harknell » Thu Jun 11, 2009 4:00 pm

Very strange. It really should be an all or nothing if it's the hotlink protection. So I suspect something else might be going on. We alternate between needing to use wp-cache on high demand days and not so I wonder if the caching is acting weird. Though that shouldn't be it either really. I just checked all of the server files and there is literally no differences between any of the images for permissions or owner, so I'm currently stumped.
Webmaster for the comic Stupid and Insane Defenders Against Chaos: http://www.onezumi.com
Webmaster for the comic Erfworld: http://www.erfworld.com
harknell
Site Admin
 
Posts: 189
Joined: Fri Dec 19, 2008 10:49 am

Re: 403 on images

Postby coke » Sun Jun 14, 2009 9:46 am

harknell wrote:Very strange. It really should be an all or nothing if it's the hotlink protection. So I suspect something else might be going on. We alternate between needing to use wp-cache on high demand days and not so I wonder if the caching is acting weird. Though that shouldn't be it either really. I just checked all of the server files and there is literally no differences between any of the images for permissions or owner, so I'm currently stumped.


Aha. It's the RSS feed; if it's checking the referral page, and I'm coming from a web based RSS reader (google reader), it hides the image; if I go to the main site URL and click on links, it's all good.

It would be nice if the images worked in the feed (or coming from the feed), but at least now I know how to see them reliably.
User avatar
coke
 
Posts: 3
Joined: Thu Jun 11, 2009 9:22 am

Re: 403 on images

Postby lpsmith » Fri Jul 10, 2009 3:49 am

Actually, yes, the 403 for the images in the rss feeds is really annoying. At the very least, the RSS should be modified so it doesn't try to show the picture and fail. Ideally, of course, it would show the image.
lpsmith
 
Posts: 2
Joined: Fri Jul 10, 2009 12:39 am

Re: 403 on images

Postby harknell » Fri Jul 10, 2009 1:42 pm

Well, it's again related to the difference between directly accessing the images or relaying them. I believe a standalone RSS program should work, but for a system that is caching the images it won't work. I'll see what we want to do at a top level on this whole issue.
Webmaster for the comic Stupid and Insane Defenders Against Chaos: http://www.onezumi.com
Webmaster for the comic Erfworld: http://www.erfworld.com
harknell
Site Admin
 
Posts: 189
Joined: Fri Dec 19, 2008 10:49 am

Re: 403 on images

Postby lpsmith » Wed Jul 22, 2009 2:54 pm

Looks like it's working now! Thanks! (I was reading it via the lj feed)
lpsmith
 
Posts: 2
Joined: Fri Jul 10, 2009 12:39 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 0 guests

cron